Case sensitivity seems lost in the specification of the install.xml file

Description

In the configuration the folder is "izPack" which is correct.

but the plugin seems to convert this to lower case and complains that
Failure during compilation process: Configuration file does not exist: ..../src/main/izpack/install.xml
which is true but I told it to look in the correct place.
Works fine on Windows but not on Linux

Environment

STS (Eclipse) on Linux

Activity

Show:
Ron Wheeler
January 16, 2018, 4:18 PM

User error

Ron Wheeler
January 16, 2018, 4:17 PM

I think that my problem was that I had not updated the plug-in configuration to keep up with the changes in the plug-in.
It was either ignoring my settings and taking reasonable defaults so that my build continued to work or it was extracting enough of my settings from the old configuration to find everything required to run under Windows.

I guess that if had not followed a reasonable setup of my project, I would have found out earlier that the plug-in had radically changed its configuration structure.

I have not tested the use of mixed case ...izPack... but I am pretty sure that this case can be closed.
Thanks for the quick response. It gave me the hint to verify my configuration which I am sure will prevent more grief later in the project if I get into more fancy setups.

Zdeněk Vaník
January 15, 2018, 1:19 PM

I was not able to reproduce this behavior on linux, in fact there is a fallback to

if attribute installFile is not specified.

Not A Bug
Your pinned fields
Click on the next to a field label to start pinning.

Assignee

Unassigned

Reporter

Ron Wheeler

Impact

Functional - non-breaking and safe in existing environments