All issues

Unattended Installation fails without logging a reason
IZPACK-1661
BuildResource are not copied in AntActionUninstallerListener
IZPACK-1618
Rollback on the quit button
IZPACK-1610
Not getting the rule field values through InstallData Object on click of custom button
IZPACK-1609
Install fails for izpack-dist-5.1.2.jar and other izpack installers on Java 9
IZPACK-1601
Java 9: java.lang.ClassCastException: java.base/jdk.internal.loader.ClassLoaders$AppClassLoader cannot be cast to java.base/java.net.URLClassLoader
IZPACK-1588
add a feature/function to convert DOS path to Unix path
IZPACK-1579
Getting some issue
IZPACK-1506
WebDir tag is creating packages but installation is failing.
IZPACK-1469
Invalid base directory: .../install.xml; The value for <installerFile> is being used for <baseDir>, WHY?
IZPACK-1457
Loose pack with zipfile and unpack="true" causes NPE
IZPACK-1440
Izpack. Both shortcuts created with same target
IZPACK-1432
UserInputPanel: Attributes missing in XSD for button field
IZPACK-1410
Unrecognized attributes to pack and refpack elements in 5.0.7
IZPACK-1390
Dynamic variables have attribute unset="false" by default, but should be "true"
IZPACK-1389
Missing attributes of <fileset> inside <pack> in installation schema
IZPACK-1388
<processor> tag nested to field <spec> not accepted during compiling UserInputSpec.xml resource
IZPACK-1387
"condition" attribute not accepted for <file> and <singlefile> tags in packs
IZPACK-1386
"os" attribute not accepted for <singlefile>/<file>/<fileset> in packs to specify OS family
IZPACK-1383
"os" attribute not accepted for <parsable>/<executable> to specify OS family
IZPACK-1382
Dynamic variables of executable type uses stderr="true" by default
IZPACK-1380
XSD is missing 'webdir' element for installation descriptor
IZPACK-1377
UserInputPanel: Field type "button" not accepted (by XSD)
IZPACK-1370
Custom conditions with fully qualified path names in type no longer accepted
IZPACK-1367
<executable>: XSD is missing attributes "type" and "class"
IZPACK-1362
element <executable>: documentation and XSD does not match
IZPACK-1361
NPE in "contains" condition
IZPACK-1335
UserInputPanel in console installers - not working dynamic evaluation of field conditions triggered by user input at one and the same panel
IZPACK-1280
Build on Debian
IZPACK-1047
Plugin does not add artifacts to project
IZPACK-1031
ConfigurationInstallerListener - installation fails with embedded DTDs in XML
IZPACK-1018
Distribution does not contain any IzPack JARs or izpack-utils resources
IZPACK-979
IzPack 5 unable to create web installer
IZPACK-961
Built-in OS conditions don't work in 5.0
IZPACK-813
Cannot modify INSTALL_PATH before TargetPanel gets called
IZPACK-798
NPE during uninstall creation at 4.3.5-SNAPSHOT
IZPACK-701
UserInput panel is ignored under console install
IZPACK-698
UserInputPanel does not changes the binding's dynamicvariable
IZPACK-697
uninstaller.jar does not have the configured merge contents in <jar>
IZPACK-695
Panel Validator does not get called
IZPACK-694
panel's custom action throws java.io.NotSerializableExcepti on:
IZPACK-689
<jar stage=install> are ignored
IZPACK-688
Invalid base directory
IZPACK-671
Console installer does nothing
IZPACK-670
Could not final class "panel class" on installer launch
IZPACK-651
Unable to launch wizard (panel) after creating the setup.exe in windows 7
IZPACK-647
JVM crash when launching IzPack-install-4.3.3.jar under Mandriva Linux 2010
IZPACK-557
Web installer fails without explanation (blank dialog box)
IZPACK-529
Installer OOMing exits without any notice
IZPACK-516
'compile' crashes with NullPointer (install.xml worked with 4.3.2, but not with 4.3.3)
IZPACK-507
issue 1 of 1409

Unattended Installation fails without logging a reason

Description

Trying to install as unattended using records of previous sessions in the terminal.
Always get the same error:
{{[ Starting automated installation ]
[ Automated installation FAILED! ]}}

I was playing with the debug logs and I can trace the logs until the checks. The last messages that I get are these:
{{2020.02.05 09:41:14 FINE: Version comparison: 11.0.3 GREATEREQUAL 1.8 (flags: 1)
2020.02.05 09:41:14 FINER: Effective number of version parts: 2
2020.02.05 09:41:14 FINER: Compare version parts: 11 <-> 1
2020.02.05 09:41:14 FINER: Raw version comparison result: 1
2020.02.05 09:41:14 FINE: 11.0.3 geq 1.8: true
2020.02.05 09:41:14 FINE: Created lock file:C:\Users\NIETOR~1\AppData\Local\Temp\2\iz-CodeProfiler for ABAP.tmp}}

I was checking the code and the last log entry comes from the lockChecker.check() and seems to be OK.
After this comes the expiredChecker.check() but no messages related seems to be also OK (it could be nice a messages telling this)
After this. it comes installerRequirementChecker.check(). In the code I see a possibility of fail without message:

In case the !condition.isTrue() and the message == null, the installation will exist without saying that the reason was an installer requirement nor which one.

I am upgrading from Izpack 4.3.3 and the AutomatedInstallation file generated is identical. In the 4.3.3 the unattended installation works and in 5.1.3 doesn't. The installation with 5.1.3 using the GUI works perfectly.

Please let me know if I can provide more information to help with this issue.

Environment

Windows 10, Windows Server 2012

Assignee

Unassigned

Reporter

Hugo Nieto Rey

Impact

None

Components

Affects versions

Priority

Highest
Configure